Abbey Games has a new community and forums! Come on over to and don't forget to mention your old username! The old forums will remain available, but read-only.

Black Screen under Linux

Post Reply
Posts: 3
Joined: Mon Jan 20, 2014 8:24 pm

Black Screen under Linux

Post by Kegen » Mon Jan 20, 2014 11:45 pm


I'm having an odd problem with the Linux version of Reus. Just a note, while I've made decent strides in my adaptation to linux from windows... I realize I'm still essentially a toddler driving a forklift (adorable, but terrifying).

Running Reus.bin.x86_64 results in a small window (that is titled Reus) followed by a full screen black window. A brief pause before my OS mouse cursor turns into a larger white (in-game) cursor followed by audio.

I can click through that audio with my mouse or keyboard. The next audio I can click through with my keyboard only. From there, more music plays (title screen?) but I still can't see anything other than a mouse cursor.

Tabbing out of the program briefly shows the smaller window filled with what looks like the title screen (and buttons to press) but it minimizes before I can do anything. Clicking on the program again opens to the same black screen.
There are no terminal errors to indcate that I'm missing something, or something didn't load.

Operating System:
Debian Wheezy (x64) with Cinnamon 1.8 desktop
Added the ia32-libs package from Wheezy
Updated the libc-bin package from the one in Jessie/Testing (this was done for another game that needed it)
Running ATI Proprietary drivers from Wheezy repository (12.6?). May need to double check that.
Added the libsdl2-2.0-0 from Wheezy-Backports as it was listed as required for MonoGame-SDL2

AMD Phenom II x4 945 at stock
8gig ram
AMD RAdeon HD 6870 (2 of them, not sure if software is running them in crossfire properly or not).

Additional info
I thought it might be Monogame that is causing the problem, but the documenation I've found thus far is largely for developers. So I came to the conclusion that as long as the package dependencies were installed, I shouldn't need ot modify Monogame (could be wrong here).

I have some other games listed as using Monogame-SDL2. I'm going to try and install them and see if they get the same problem. I'll post here with updates.

Until then, any suggestions would be helpful.
Thank you

Posts: 3
Joined: Mon Jan 20, 2014 8:24 pm

Re: Black Screen under Linux

Post by Kegen » Tue Jan 21, 2014 12:48 am

Follow up.

Installed FEZ and Capsized (two games noted for using Monogame-SDL2).

FEZ showed the same problems as Reus.
Capsized worked in window mode, but the screen went purple in full screen mode.

Both FEZ and Capsized returned these errors:
EXT_swap_control_tear unsupported. Fall back to standard VSync.
Couldn't find XDG_DATA_HOME.

They don't sound like the source of the issue, but who knows.

Posts: 3
Joined: Mon Jan 20, 2014 8:24 pm

Re: Black Screen under Linux

Post by Kegen » Tue Jan 21, 2014 3:18 am

Good news! Problem (Semi) Solved!

As mentioned in my first post, I am using Cinnamon as a desktop environment (if that's the right term).
Sadly, it's the reason I can't run these games full screen. Switching to Gnome made everything work without a hitch.

Pity too, because I really like Cinnamon.

Post Reply