Abbey Games has a new community and forums! Come on over to and don't forget to mention your old username! The old forums will remain available, but read-only.

Known issues ( since May 20 2013 ) [OLD VERSION WINDOWS]

User avatar
Posts: 626
Joined: Mon May 20, 2013 2:20 am
Location: France, Ile de France

Known issues ( since May 20 2013 ) [OLD VERSION WINDOWS]

Post by Touriste » Thu May 23, 2013 5:10 pm

Hello !

Welcome to the F.A.P topic (Frequently Asked Problems) [What a bad joke]

I am trying to do a summary of the known issues that occurred since the patch on Reus.
I recommend you to install the game through Steam as most people will play on this platform !

The list may not be full and may not be updated daily, so be sure to check the last edit !

  • Reinstall
    Verify game cache if you are on Steam [ Right click on game> Properties> Local Files> Verify ... ]
    Install latest drivers for your computer


Game not starting ?
  • Run everything you can in administrator mod
    (Steam, game, installation programs (who are about the game, ofc !)
  • Check that the Visual Studio 2010 (x86 or x64) redist is installed and try removing previous versions.
  • Have this installled XNA 4.0 Refresh
    Make sure you install the XNA framework with your own user account.
    If you have an older version of XNA and the game is not working, uninstall the old version
Game not starting - blackscreen issue ?

Make sure to update your video codec, K-Lite is great for that, you can download it here.

Game not starting and you have other games (like Terraria) not working too ?

Here's a guide that will help you fix this s**t up !

Game won't start - AudioException ?

  • This usually happens when there is no audio device active on the computer. Check your default playback device.
Game crashes after alt tabing ?
M4st3rM1nd wrote:Not really a big solution but if you could try to run in windowed mode. This means you don't really have to alt-tab out of the game.
You are on a laptop and can't run the game because your computer does not fit the requirements ?
  • Check if your laptop has two video modes.

    One may be the default "graphic card" provided by the constructor.
    The second may be your better "graphic card". DxDiag picks up the Intel chip by default.

    Try make Reus working by right-clicking on it and choosing 'Run with graphics processor -> High-performance (or something like that) video card'.
    hugorune wrote:I would suspect other laptops with 3D graphics chips may need something similar.
  • If you see this first line in the error report :

    Code: Select all

    System.InvalidOperationException: Error decompressing content data.
    Then look
    Bas wrote:This can only be an issue with the file that is being loaded. The file is loaded corruptly meaning that either the file is corrupt (likely) or there is something wrong with your hardrive. Try reinstalling the game (on another hard drive if reinstall is not working).

Problems patching through GoG.COM ?

It is a topic about a problem when patching !
I am too lazy to sum it up, sorry.

Be sure to report every bug you encounter !

None of this worked ?

Create a new topic and attach save game located in "My documents>Reus>saves"

If the game crashed, check the steam install directory :
"program files/Steam/steamapps/common/Reus/"
For a non-Steam install it should be in your installation folder
And copy past the error report it created.

No Error Report created from your bug ?

Check your windows event log by typing Event Viewer into the start menu and look for the applications log.
If something went wrong with starting up Reus (likely) it will be logged there.
Then copy/paste the error reported !


PS : If you know another thing that could help anyone out with a problem, send me a PM or just post your own reply :) ( If you want credits I will quote you np ! )

PSS : If there is something that is not written correctly, be sure to point it out to me !
Last edited by Touriste on Thu May 30, 2013 8:25 pm, edited 5 times in total.

Posts: 1
Joined: Sun May 26, 2013 6:04 pm

Re: Known issues ( since patch )

Post by man0cels0 » Sun May 26, 2013 6:10 pm

Hello. I bought it throough steam,and my very upsetting problem is the fonts get way too small inside the actual game. In the menus its like about 14, and when the game starts it goes to like 5,6 or 7. So changing resolution doesn't make it either better nor worse. thanks...

User avatar
Posts: 626
Joined: Mon May 20, 2013 2:20 am
Location: France, Ile de France

Re: Known issues ( since patch )

Post by Touriste » Mon May 27, 2013 2:57 pm

man0cels0 wrote:Hello. I bought it throough steam,and my very upsetting problem is the fonts get way too small inside the actual game. In the menus its like about 14, and when the game starts it goes to like 5,6 or 7. So changing resolution doesn't make it either better nor worse. thanks...
They are working on it : (source) ... 512790312/

Posts: 2
Joined: Mon May 27, 2013 5:10 pm

Re: Known issues ( since patch )

Post by shivarider » Mon May 27, 2013 5:12 pm

Hi all

My Safegame of a 120 min Game Crashes after 90min Gametime everytime i load it and play it for 2 minutes.

Is there a workaround for this ?

Thread: Main

System.NullReferenceException: Object reference not set to an instance of an object.
at Reus.Model.Mines.CivStatActivationRequirement.GetCurrentValue(Civilization owner)
at Reus.Model.Mines.CivStatActivationRequirement.CouldActivate(MineAsset mine)
at Reus.Model.Mines.CivStatActivationRequirement.CivStatActivationListener.OnValueChanged(Object sender, PropertyChangedEventArgs`1 e)
at System.EventHandler`1.Invoke(Object sender, TEventArgs e)
at Reus.Model.PropertyChangedEventCollection`1.InvokePropertyChanged(Object sender, T property, PropertyChangedEventArgs`1 args)
at Reus.Model.Civilizations.Civilization.set_Wealth(Single value)
at Reus.Model.Civilizations.Civilization.IncreaseStatInstantly(CivMainStat target, Single amount, Boolean ignoreGreed, Boolean ignoreMax)
at Reus.Model.Civilizations.Civilization.ReceiveWarSpoils(Civilization victim)
at Reus.Controller.WarController.OnParticipantDestroyed(Object sender, EventArgs e)
at System.EventHandler.Invoke(Object sender, EventArgs e)
at Reus.Model.Civilizations.Civilization.OnDestroyed(EventArgs e)
at Reus.Model.Civilizations.CivilizationCollection.OnCivilizationRemoved(Civilization c)
at Reus.Model.Civilizations.CivilizationCollection.RemoveItem(Int32 index)
at System.Collections.ObjectModel.Collection`1.Remove(T item)
at Reus.Controller.Civilizations.Government.DestroyCivilization(CivilizationControl civControl)
at Reus.Controller.Civilizations.Government.UpdateCivilization(CivilizationControl civControl, GameTime gameTime)
at Reus.Controller.Civilizations.Government.<>c__DisplayClass5.<Update>b__4(CivilizationControl cc)
at System.Collections.Generic.List`1.ForEach(Action`1 action)
at Reus.Controller.Civilizations.Government.Update(GameTime gameTime)
at Reus.Controller.PlanetController.Update(GameTime gameTime)
at Reus.GameplayComponent.Update(GameTime gameTime)
at Microsoft.Xna.Framework.Game.Update(GameTime gameTime)
at (Object , GameTime )
at 冷櫎띂ફ迷ಏ泈.ウ沊鉨㚽ᕼ᠃ᮩ(Object , GameTime 볤샑辋䴠簹連夯촵)
at ≬鑜瓜쓄憎쨢㣠㭄.Update(GameTime gameTime)
at Microsoft.Xna.Framework.Game.Tick()
at Microsoft.Xna.Framework.Game.HostIdle(Object sender, EventArgs e)
at Microsoft.Xna.Framework.GameHost.OnIdle()
at Microsoft.Xna.Framework.WindowsGameHost.RunOneFrame()
at Microsoft.Xna.Framework.WindowsGameHost.ApplicationIdle(Object sender, EventArgs e)
at System.Windows.Forms.Application.ThreadContext.System.Windows.Forms.UnsafeNativeMethods.IMsoComponent.FDoIdle(Int32 grfidlef)
at System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(IntPtr dwComponentID, Int32 reason, Int32 pvLoopData)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.Run(Form mainForm)
at Microsoft.Xna.Framework.WindowsGameHost.Run()
at Microsoft.Xna.Framework.Game.RunGame(Boolean useBlockingRun)
at (Object )
at 絕㲝﷦陼ﱾㆺ݃.䅾∮吒赐⻪엞束(Object )
at 弛㻗惦汓糳侏㚼.抏﬷녥풞븴矫()
at 弛㻗惦汓糳侏㚼.눵萩타ഠ颜ᇕ粐螾(String[] 嗕䛍봛ミ莏㵇꠶⹅)

0x0000 Reus.exe->ꂈ姹틌躤韃.₁땊뇔틶⎐⨥⟂ಶ
0x017d Reus.exe->弛㻗惦汓糳侏㚼.뀆悀潴┈Ꮝ碂�
0x0007 Reus.Model.dll->Reus.Model.Mines.CivStatActivationRequirement.GetCurrentValue
0x0000 Reus.Model.dll->Reus.Model.Mines.CivStatActivationRequirement.CouldActivate
0x0000 Reus.Model.dll->Reus.Model.Mines.CivStatActivationRequirement+CivStatActivationListener.OnValueChanged
0xffffffff CommonLanguageRuntimeLibrary->System.EventHandler`1.Invoke
0x0018 Reus.Model.dll->Reus.Model.PropertyChangedEventCollection`1.InvokePropertyChanged
0x0019 Reus.Model.dll->Reus.Model.Civilizations.Civilization.set_Wealth
0x007d Reus.Model.dll->Reus.Model.Civilizations.Civilization.IncreaseStatInstantly
0x00ca Reus.Model.dll->Reus.Model.Civilizations.Civilization.ReceiveWarSpoils
0x004c Reus.exe->Reus.Controller.WarController.OnParticipantDestroyed
0xffffffff CommonLanguageRuntimeLibrary->System.EventHandler.Invoke
0x006c Reus.Model.dll->Reus.Model.Civilizations.Civilization.OnDestroyed
0x000b Reus.Model.dll->Reus.Model.Civilizations.CivilizationCollection.OnCivilizationRemoved
0x0016 Reus.Model.dll->Reus.Model.Civilizations.CivilizationCollection.RemoveItem
0x002e CommonLanguageRuntimeLibrary->System.Collections.ObjectModel.Collection`1.Remove
0x0051 Reus.exe->Reus.Controller.Civilizations.Government.DestroyCivilization
0x0051 Reus.exe->Reus.Controller.Civilizations.Government.UpdateCivilization
0x0012 Reus.exe->Reus.Controller.Civilizations.Government+<>c__DisplayClass5.<Update>b__4
0x001f CommonLanguageRuntimeLibrary->System.Collections.Generic.List`1.ForEach
0x003c Reus.exe->Reus.Controller.Civilizations.Government.Update
0x00f2 Reus.exe->Reus.Controller.PlanetController.Update
0x008e Reus.exe->Reus.GameplayComponent.Update
0x0058 Microsoft.Xna.Framework.Game.dll->Microsoft.Xna.Framework.Game.Update

User avatar
Posts: 626
Joined: Mon May 20, 2013 2:20 am
Location: France, Ile de France

Re: Known issues ( since patch )

Post by Touriste » Mon May 27, 2013 7:05 pm

This error has been reported a few times, it should be fixed in the next patch.
I think it is because of a missing letter in a word.

No more initiatives.
Last edited by Touriste on Mon May 27, 2013 10:49 pm, edited 1 time in total.

King of the Beta
Posts: 423
Joined: Wed Nov 28, 2012 11:19 am

Re: Known issues ( since patch )

Post by Bas » Mon May 27, 2013 10:33 pm

Your crash has to do with villages with overlapping borders (which shouldnt happen). Its fixed in the next patch. The workaround is to not place mines in these overlapping areas.

Posts: 2
Joined: Mon May 27, 2013 5:10 pm

Re: Known issues ( since patch )

Post by shivarider » Tue May 28, 2013 8:50 am

Thank you Guys fpr the Answers, i will be spotting out theese mines and destroy it

User avatar
Posts: 6
Joined: Tue May 28, 2013 8:44 pm

Re: Known issues ( since patch )

Post by Highpriest314 » Tue May 28, 2013 8:47 pm

I'v already done whats said on the post but i still get the same response from the game, it is still asking me for that God forsaken XNA format even after i installed the one that's posted and even changed the owner settings to administrator. Iv reinstalled the game in 5 times now and still it gives me the same response.. please help me!

User avatar
Posts: 626
Joined: Mon May 20, 2013 2:20 am
Location: France, Ile de France

Re: Known issues ( since patch )

Post by Touriste » Tue May 28, 2013 8:54 pm

Can you run a DxDiag and post it here ?
Open DirectX Diagnostic Tool by clicking the Start button , typing dxdiag in the Search box.

Posts: 1
Joined: Wed May 29, 2013 3:42 am

Re: Known issues ( since patch )

Post by NightMareOG » Wed May 29, 2013 3:49 am

i did the dxdiag thing, and it says im running on directx 9 even tho i've installed dx 10-11 and have run other games that require dx10 how can i update it?

this report: 5/28/2013, 21:39:41
Machine name: USER-2132FEB17C
Operating System: Windows XP Professional (5.1, Build 2600) Service Pack 3 (2600.xpsp_sp3_gdr.130307-0422)
Language: English (Regional Setting: English)
System Manufacturer: PCCHIPS
System Model: A15G
BIOS: Default System BIOS
Processor: AMD Athlon(tm) 64 X2 Dual Core Processor 4200+, MMX, 3DNow (2 CPUs), ~2.2GHz
Memory: 960MB RAM
Page File: 717MB used, 1597MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 9.0c (4.09.0000.0904)
DX Setup Parameters: Not found
DxDiag Version: 5.03.2600.5512 32bit Unicode


Post Reply