Abbey Games has a new community and forums! Come on over to https://community.abbeygames.com and don't forget to mention your old username! The old forums will remain available, but read-only.

Crippling lag from villages

Post Reply [phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable
weckar
Posts:5
Joined:Sun May 26, 2013 1:29 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable
Crippling lag from villages

Post by weckar » Sun May 26, 2013 1:33 am

Hey there,
I hope someone can help me with this issue:

The game plays fine, but sometimes a crippling lag takes over. I've tried to narrow down the cause somewhat. It only happens when a village (or any part of it) is on screen. If I roll away, it immediately disappears. Also, it only seems to occur when there are two or more villages on my planet.

Now, I don't intend to play solo-village all the time, so has someone else experienced/solved this?

Thanks in advance

Bas
King of the Beta
Posts:423
Joined:Wed Nov 28, 2012 11:19 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable

Re: Crippling lag from villages

Post by Bas » Mon May 27, 2013 9:56 am

Can you post you PC specs? Or preferably a DXDiag export?

weckar
Posts:5
Joined:Sun May 26, 2013 1:29 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable

Re: Crippling lag from villages

Post by weckar » Mon May 27, 2013 3:38 pm

I forget, how do I get to those again in a most reliable fashion?

User avatar
Touriste
Posts:626
Joined:Mon May 20, 2013 2:20 am
Location:France, Ile de France
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable

Re: Crippling lag from villages

Post by Touriste » Mon May 27, 2013 4:08 pm

Open DirectX Diagnostic Tool by clicking the Start button, typing dxdiag in the Search box.
For your specs, you go in control panel, then go into "system" you will have RAM and processor showing.

weckar
Posts:5
Joined:Sun May 26, 2013 1:29 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable

Re: Crippling lag from villages

Post by weckar » Tue May 28, 2013 5:26 am

Thank you.

Code: Select all

   Operating System: Windows XP Professional (5.1, Build 2600) Service Pack 3 (2600.xpsp_sp3_gdr.130307-0422)
           Language: English (Regional Setting: English)
System Manufacturer: Dell Inc.
       System Model: Vostro 420 Series 
               BIOS: Default System BIOS
          Processor: Intel(R) Core(TM)2 Quad  CPU   Q8200  @ 2.33GHz (4 CPUs)
             Memory: 3070MB RAM
          Page File: 2878MB used, 4128MB available
        Windows Dir: E:\WINDOWS
    DirectX Version: DirectX 9.0c (4.09.0000.0904)
DX Setup Parameters: Not found
     DxDiag Version: 5.03.2600.5512 32bit Unicode

---------------
Display Devices
---------------
        Card name: ATI Radeon HD 3600 Series      
     Manufacturer: ATI Technologies Inc.
        Chip type: ATI Radeon Graphics Processor (0x9598)
         DAC type: Internal DAC(400MHz)
       Device Key: Enum\PCI\VEN_1002&DEV_9598&SUBSYS_22421028&REV_00
   Display Memory: 256.0 MB
     Current Mode: 1280 x 1024 (32 bit) (60Hz)
          Monitor: Default Monitor
  Monitor Max Res: 
      Driver Name: ati2dvag.dll
   Driver Version: 6.14.0010.7206 (English)
      DDI Version: 9 (or higher)
Driver Attributes: Final Retail
 Driver Date/Size: 7/8/2011 05:22:08, 302592 bytes
      WHQL Logo'd: n/a
  WHQL Date Stamp: n/a
              VDD: n/a
         Mini VDD: ati2mtag.sys
    Mini VDD Date: 7/8/2011 06:12:46, 7023104 bytes
Device Identifier: {D7B71EE2-D6D8-11CF-BE6F-4802A1C2CB35}
        Vendor ID: 0x1002
        Device ID: 0x9598
        SubSys ID: 0x22421028
      Revision ID: 0x0000
      Revision ID: 0x0000
      Video Accel: ModeMPEG2_C ModeMPEG2_D ModeWMV8_A ModeWMV9_A 
 Deinterlace Caps: {6E8329FF-B642-418B-BCF0-BCB6591E255F}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive 
                   {335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch 
                   {3C5323C1-6FB7-44F5-9081-056BF2EE449D}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,2) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive 
                   {552C0DAD-CCBC-420B-83C8-74943CF9F1A6}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,2) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive 
                   {6E8329FF-B642-418B-BCF0-BCB6591E255F}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive 
                   {335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch 
         Registry: OK
     DDraw Status: Enabled
       D3D Status: Enabled
       AGP Status: Enabled
DDraw Test Result: Not run
 D3D7 Test Result: Not run
 D3D8 Test Result: Not run
 D3D9 Test Result: Not run


Also, I did a little more experimenting. This lag happens whenever a combination of two or more NPC spawners are within the drawing frame. That's villages, but also animals. Maybe that helps.

Darexon
Posts:8
Joined:Sun May 26, 2013 12:59 pm
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable

Re: Crippling lag from villages

Post by Darexon » Tue May 28, 2013 6:15 am

I don't know if this will help but go to your graphics card`s settings and enable triplebuffering and vsyncing for this game, it usually fixes my lag.

Bas
King of the Beta
Posts:423
Joined:Wed Nov 28, 2012 11:19 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable

Re: Crippling lag from villages

Post by Bas » Tue May 28, 2013 10:49 am

Thanks very much. I am looking into this. :)

Post Reply
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable